7a5e17a9817bb24f4646bd1038abe9fad70ef9fc
[openembedded.git] / recipes / linphone / linphone_0.12.2.bb
1 LICENSE = "GPL"
2 SECTION = "x11/utils"
3 PR = "r2"
4
5 DESCRIPTION = "SIP-based IP phone (GPE edition)"
6 DEPENDS = "libosip gtk+ libogg libgnomeui"
7 SRC_URI = "http://simon.morlat.free.fr/download/0.12.2/source/linphone-${PV}.tar.gz \
8         file://osip-lossage.patch;patch=1 \
9         file://disable-gtk-doc.patch;patch=1"
10
11 FILES_${PN} += "${datadir}/linphonec"
12
13 EXTRA_OECONF = "--disable-gtk-doc"
14
15 inherit autotools
16
17 do_configure() {
18         # ffmpeg is in AC_SUBDIRS, but doesn't actually use autoconf.
19         # Autoreconf will try to recurse into there and blow up.
20         for dir in . speex oRTP osipua; do
21                 ( cd $dir; libtoolize --force; aclocal; automake; autoconf )
22         done
23
24         oe_runconf
25 }
26
27 do_install_append() {
28         mv ${D}${datadir}/gnome/apps/Internet ${D}${datadir}/applications
29         rm -f ${D}${datadir}/sounds/linphone/hello*.wav
30         rm -f ${D}${datadir}/sounds/linphone/rings/oldphone.wav
31 }