Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / libvorbis / libvorbis_1.0.1.bb
1 SECTION = "libs"
2 DEPENDS = "libogg"
3 DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
4 that is free of intellectual property restrictions. libvorbis \
5 is the main vorbis codec library."
6 LICENSE = "BSD"
7 PR = "r2"
8
9 SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libvorbis-${PV}.tar.gz \
10 file://m4.patch;patch=1"
11
12 inherit autotools  pkgconfig
13
14 # vorbisfile.c reveals a problem in the gcc register spilling for the
15 # thumb instruction set...
16 FULL_OPTIMIZATION_thumb = "-O0"
17
18 EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
19                 --with-ogg-includes=${STAGING_INCDIR}"
20
21 do_stage () {
22         oe_libinstall -a -so -C lib libvorbis ${STAGING_LIBDIR}
23         oe_libinstall -a -so -C lib libvorbisfile ${STAGING_LIBDIR}
24         oe_libinstall -a -so -C lib libvorbisenc ${STAGING_LIBDIR}
25
26         install -d ${STAGING_INCDIR}/vorbis
27         install -m 0644 include/vorbis/vorbisenc.h \
28                         include/vorbis/vorbisfile.h \
29                         include/vorbis/codec.h ${STAGING_INCDIR}/vorbis/
30         install -d ${STAGING_DATADIR}/aclocal
31         install -m 0644 vorbis.m4 ${STAGING_DATADIR}/aclocal/
32 }