libsdl-x11_1.2.14: remove INC_PR, didn't notice that require libsdl.inc is actually...
[openembedded.git] / recipes / libsdl / libsdl-x11_1.2.14.bb
1 # Do not use the include in 1.2.14 as it has a lot of unneeded munging that applies to old versions.
2 #require libsdl.inc
3
4 DESCRIPTION = "Simple DirectMedia Layer (X11 and Framebuffer support)"
5 SECTION = "libs"
6 PRIORITY = "optional"
7 LICENSE = "LGPL"
8 DEPENDS = "alsa-lib virtual/libgl virtual/libx11 libxext tslib"
9 DEPENDS_avr32 = "alsa-lib virtual/libx11 libxext tslib"
10 PROVIDES = "virtual/libsdl"
11 PR = "r2"
12
13 SRC_URI = " \
14   http://www.libsdl.org/release/SDL-${PV}.tar.gz \
15 "
16
17 S = "${WORKDIR}/SDL-${PV}"
18
19 inherit autotools binconfig pkgconfig
20
21 EXTRA_OECONF = " \
22   --disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
23   --enable-file --enable-oss --enable-alsa --disable-esd --disable-arts \
24   --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
25   --disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
26   --enable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
27   --disable-video-xbios --disable-video-gem --disable-video-dummy \
28   --enable-video-opengl --enable-input-events --enable-pthreads \
29   --disable-video-picogui --disable-video-qtopia --enable-dlopen \
30   --enable-input-tslib \
31 "
32
33 do_configure() { 
34   oe_runconf
35 }
36
37 do_configure_append () {
38   cd ${S}
39
40   # prevent libtool from linking libs against libstdc++, libgcc, ...
41   cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
42   mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
43 }
44
45 do_stage() {
46   autotools_stage_all           
47   rm ${STAGING_LIBDIR}/libSDL.la
48 }
49
50 FILES_${PN} = "${libdir}/lib*.so.*"
51 FILES_${PN}-dev += "${bindir}/*config"