libsdl: Add 1.2.14 (and native). Note: Does not use libsdl.inc as that has hacks...
[openembedded.git] / recipes / libsdl / libsdl-mixer_1.2.6.bb
1 DESCRIPTION = "Simple DirectMedia Layer mixer library."
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libsdl libmikmod libvorbis"
5 LICENSE = "LGPL"
6 PR = "r3"
7
8 SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
9 S = "${WORKDIR}/SDL_mixer-${PV}"
10
11 export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
12
13 inherit autotools
14
15 EXTRA_OECONF = "--disable-music-mp3"
16 # although we build smpeg... need to find out how
17 # to deal with optional dependencies
18
19 do_stage() {
20         oe_libinstall -so libSDL_mixer ${STAGING_LIBDIR}
21         ln -sf libSDL_mixer.so ${STAGING_LIBDIR}/libSDL_mixer-1.2.so
22         install -m 0644 SDL_mixer.h ${STAGING_INCDIR}/SDL/SDL_mixer.h
23 }
24