libsdl: Add 1.2.14 (and native). Note: Does not use libsdl.inc as that has hacks...
[openembedded.git] / recipes / libsdl / libsdl-mixer_1.2.11.bb
1 DESCRIPTION = "Simple DirectMedia Layer mixer library."
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libsdl flac libmikmod libvorbis"
5 LICENSE = "LGPL"
6
7 PR = "r1"
8
9 SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
10            file://fix-flac-madness.diff;patch=1"
11
12 S = "${WORKDIR}/SDL_mixer-${PV}"
13
14 export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
15
16 inherit autotools_stage
17
18 EXTRA_OECONF = "--disable-music-mp3"
19 # although we build smpeg... need to find out how
20 # to deal with optional dependencies
21
22 do_compile() {
23         # Override SDL_LIBS to include a linker rpath so the linker
24         # can find the correct libdl.so when it links playwave to
25         # libSDL_mixer.so.
26         oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
27 }