Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org...
[openembedded.git] / recipes / libgmime / libgmime_2.2.23.bb
1 LICENSE = "LGPL"
2 DESCRIPTION = "Runtime libraries for parsing and creating MIME mail"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 DEPENDS = "glib-2.0 zlib"
6 SRC_URI = "http://ftp.acc.umu.se/pub/GNOME/sources/gmime/2.2/gmime-${PV}.tar.bz2 \
7            file://configure-cross.patch;patch=1 \
8            file://iconv-detect.h"
9 EXTRA_OECONF += "--disable-mono"
10 S = "${WORKDIR}/gmime-${PV}"
11
12 inherit autotools_stage lib_package binconfig
13
14 export ac_cv_have_iconv_detect_h=yes
15 do_configure_append = "cp ${WORKDIR}/iconv-detect.h ${S}"
16
17 # we do not need GNOME 1 gnome-config support
18 do_install_append () {
19         rm -f ${D}${libdir}/gmimeConf.sh
20 }