Merge branch 'master' of git://dev.doredevelopment.dk/oe-micro into org.openembedded.dev
[openembedded.git] / recipes / libetpan / libetpan_0.46.bb
1 DESCRIPTION = "libetpan is a library for communicating with mail and news servers. \
2 It supports the protocols SMTP, POP3, IMAP and NNTP."
3 HOMEPAGE = "http://www.etpan.org"
4 SECTION = "libs"
5 DEPENDS = "gnutls"
6 LICENSE = "BSD"
7 PR = "r0"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
10            file://honor-oe-lflags.patch;patch=1"
11
12 inherit autotools pkgconfig gettext binconfig
13
14 EXTRA_OECONF = "--without-openssl --with-gnutls --disable-db"
15
16 PARALLEL_MAKE = ""
17
18 do_stage() {
19         autotools_stage_all
20 }
21
22 FILES_${PN} = "${libdir}/lib*.so.*"
23 FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"