linux-kexecboot: uniform the SRC_URI (defconfig in kernel recipe)
[openembedded.git] / recipes / kexecboot / linux-kexecboot_2.6.26.bb
1 require linux-kexecboot.inc
2
3 DEFAULT_PREFERENCE = "-1"
4 DEFAULT_PREFERENCE_qemuarm = "-1"
5 DEFAULT_PREFERENCE_qemux86 = "-1"
6 DEFAULT_PREFERENCE_spitz = "1"
7 DEFAULT_PREFERENCE_collie = "1"
8 DEFAULT_PREFERENCE_c7x0 = "1"
9 DEFAULT_PREFERENCE_akita = "1"
10
11 # Handy URLs
12 # git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=ef7d1b244fa6c94fb76d5f787b8629df64ea4046
13 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2
14 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/linux-2.6.20-rc4.tar.bz2
15 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-2.6.18-rc6.bz2;patch=1
16 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/snapshots/patch-2.6.18-rc2-git1.bz2;patch=1
17 # ${KERNELORG_MIRROR}/pub/linux/kernel/people/alan/linux-2.6/2.6.10/patch-2.6.10-ac8.gz;patch=1
18 # ${KERNELORG_MIRROR}/pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;patch=1
19
20 # Patches submitted upstream are towards top of this list 
21 # Hacks should clearly named and at the bottom
22 SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2 \
23            ${RPSRC}/lzo_jffs2_sysfs-r1.patch;patch=1 \
24            ${RPSRC}/hx2750_base-r34.patch;patch=1 \
25            ${RPSRC}/hx2750_bl-r9.patch;patch=1 \
26            ${RPSRC}/hx2750_pcmcia-r3.patch;patch=1 \
27            ${RPSRC}/pxa_keys-r9.patch;patch=1 \
28            ${RPSRC}/tsc2101-r19.patch;patch=1 \
29            ${RPSRC}/hx2750_test1-r8.patch;patch=1 \
30            ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
31            ${RPSRC}/pm_changes-r1.patch;patch=1 \
32            ${RPSRC}/locomo_kbd_tweak-r2.patch;patch=1 \
33 #           ${RPSRC}/pxa27x_overlay-r8.patch;patch=1 \
34            ${RPSRC}/w100_extaccel-r2.patch;patch=1 \
35            ${RPSRC}/w100_extmem-r1.patch;patch=1 \
36            ${RPSRC}/poodle_pm-r6.patch;patch=1 \
37            ${RPSRC}/poodle_lcd_hack-r0.patch;patch=1 \
38            ${RPSRC}/poodle_asoc_fix-r1.patch;patch=1 \
39            file://zaurus-i2c-init.patch;patch=1;status=upstream \
40 #           ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable \
41            ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
42            file://hostap-monitor-mode.patch;patch=1;status=unmergable \
43            file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1;status=unmergable \
44            ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack \
45            ${RPSRC}/mmcsd_no_scr_check-r2.patch;patch=1;status=hack \
46            ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
47            ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
48            file://sharpsl-rc-r1.patch;patch=1 \
49            file://spitz_h_rewrite.patch;patch=1 \
50            file://pxa-serial-hack.patch;patch=1;status=hack \
51            file://connectplus-remove-ide-HACK.patch;patch=1;status=hack \
52            file://connectplus-prevent-oops-HACK.patch;patch=1;status=hack \
53            file://htcuni.patch;patch=1 \
54            file://versatile-armv6.patch;patch=1 \
55            file://defconfig"
56
57 # FIXMEs before made default       
58 # ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack
59
60
61 # Add this to enable pm debug code (useful with a serial lead)
62 #  ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
63
64 # Disabled until I find the reason this gives issues with cdc_subset
65 #            ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
66
67
68 SRC_URI_append_collie = "\
69         file://collie.patch;patch=1 \
70         file://collie_keymap.patch;patch=1 \
71 "
72
73 SRC_URI_append_htcuniversal ="\
74         file://htcuni-acx.patch;patch=1;status=external \
75         "
76
77 SRC_URI_append_zylonite ="\
78         file://pxa_fb_overlay.patch;patch=1 \
79         file://zylonite-boot.patch;patch=1 \
80         file://zylonite_mtd-r0.patch;patch=1 \
81         file://zylonite_touch-r0.patch;patch=1 \
82         file://zylonite_keypad-r0.patch;patch=1 \
83         "
84
85 S = "${WORKDIR}/linux-2.6.26"