Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / iperf / iperf_1.7.0.bb
1 SECTION = "console/network"
2 DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
3 HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
4 LICENSE = "BSD"
5 PR = "r1"
6
7 SRC_URI = "http://dast.nlanr.net/Projects/Iperf/iperf-${PV}-source.tar.gz \
8         file://socketaddr-h-errno.diff;patch=1"
9
10 inherit autotools
11
12 S="${WORKDIR}/iperf-${PV}/cfg"
13
14 do_configure() {
15         oe_runconf
16 }
17
18 do_compile() {
19         cd ${WORKDIR}/iperf-${PV}
20         oe_runmake
21 }
22
23 do_install() {
24         cd ${WORKDIR}/iperf-${PV}/src
25         oe_runmake INSTALL_DIR=${D}${bindir} install
26 }