9c2b1befed4c850590858aecf1493bfb03369cb0
[openembedded.git] / recipes / images / illume-image.bb
1 #------------------------------------------------------
2 # Rasterman Illume Image Recipe
3 #------------------------------------------------------
4
5 IMAGE_LINGUAS = "en-us de-de fr-fr pt-br ca-es zh-cn zh-tw bg-bg cs-cz da-dk nl-nl fi-fi hu-hu it-it ja-jp ko-kr nb-no pl-pl ru-ru sk-sk sl-si es-ar sv-se"
6
7 # getting the base system up
8 BASE_INSTALL = "\
9   angstrom-libc-fixup-hack \
10   ${MACHINE_TASK_PROVIDER} \
11   task-base \
12   netbase \
13   sysfsutils \
14   wireless-tools \
15   modutils-initscripts \
16   module-init-tools-depmod \
17   pointercal \
18   tslib-conf \
19 #  prelink \
20 #  exquisite \
21 #  exquisite-themes \
22 #  exquisite-theme-illume \
23 #  rsync \
24 #  screen \
25 #  fbset \
26 #  fbset-modes \
27 "
28
29 # Some machines don't set a *runtime* provider for X, so default to Xfbdev here
30 # virtual/xserver won't work, since the kdrive recipes will build multiple xserver packages
31 XSERVER ?= "xserver-kdrive-fbdev"
32
33 # getting an X window system up
34 X_INSTALL = "\
35   libx11-locale \
36   localedef \
37   glibc-charmap-utf-8 \
38   shared-mime-info \
39   mime-support \
40   e-wm \
41   e-wm-sysactions \
42   e-wm-config-illume \
43   e-wm-config-standard \
44   e-wm-config-netbook \
45   e-wm-config-minimalist \
46   e-wm-config-scaleable \
47   ${XSERVER} \
48   xserver-kdrive-splash-illume \
49   xserver-kdrive-common \
50   xserver-nodm-init \
51   xauth \
52   xhost \
53   xset \
54   xrandr \
55   \
56   fontconfig-utils \
57   \
58   ttf-dejavu-common \
59   ttf-dejavu-sans \
60   ttf-dejavu-serif \
61   ttf-dejavu-sans-mono \
62   ttf-arphic-uming \
63 "
64 DEV_INSTALL = "\
65   task-native-sdk \
66   e-wm-dev \
67   task-proper-tools \
68   ntpdate \
69   nfs-utils-client \
70   gdb \
71   pkgconfig \
72   ltrace \
73   perl-module-file-path \
74 "
75
76 # useful command line tools
77 TOOLS_INSTALL = "\
78   dosfstools \
79   lsof \
80   mickeydbus \
81   mtd-utils \
82   nano \
83   powertop \
84   sysstat \
85 "
86
87 # audio
88 AUDIO_INSTALL = "\
89   alsa-oss \
90   alsa-state \
91   alsa-utils-aplay \
92   alsa-utils-amixer \
93   gst-meta-audio \
94   ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mad', d)} \
95   gst-plugin-modplug \
96   gst-plugin-sid \
97   fso-sounds \
98 "
99
100 GTK_INSTALL = "\
101   vala-terminal \
102   gpe-scap \
103 "
104
105 # FIXME these should rather be part of alsa-state,
106 # once Om stabilizes them...
107 AUDIO_INSTALL_append_om-gta01 = "openmoko-alsa-scenarios"
108 AUDIO_INSTALL_append_om-gta02 = "openmoko-alsa-scenarios"
109
110 # GLES libs - put them on if the platform has them
111 GLES_INSTALL = ""
112 GLES_INSTALL_append_beagleboard  = "libgles-omap3 devmem2"
113 GLES_INSTALL_append_omap-3430sdp = "libgles-omap3"
114 GLES_INSTALL_append_omap-3430ldp = "libgles-omap3"
115 GLES_INSTALL_append_omap3evm     = "libgles-omap3"
116 #GLES_INSTALL_append_overo        = "libgles-omap3"
117 GLES_INSTALL_append_mx31ads      = "libgles-mx31"
118 GLES_INSTALL_append_mx31litekit  = "libgles-mx31"
119 GLES_INSTALL_append_zylonite     = "libgles-zylonite"
120
121 # python
122 PYTHON_INSTALL = "\
123 #  task-python-efl \
124 #  python-codecs \
125 #  python-gst \
126 "
127
128 # zhone
129 ZHONE_INSTALL = "\
130   fso-gsm0710muxd \
131   frameworkd \
132   fso-gpsd \
133   zhone \
134 "
135
136 # additional apps
137 APPS_INSTALL = "\
138    elementary-alarm \
139    expedite \
140    expedite-themes \
141    libefso \
142    essential-dialer \
143    elementary-sms \
144 "
145
146 IMAGE_INSTALL = "\
147   ${BASE_INSTALL} \
148   ${GLES_INSTALL} \
149   ${X_INSTALL} \
150   ${GTK_INSTALL} \
151   ${AUDIO_INSTALL} \
152   ${TOOLS_INSTALL} \
153   ${PYTHON_INSTALL} \
154 #  ${ZHONE_INSTALL} \
155   ${APPS_INSTALL} \
156   ${DEV_INSTALL} \
157 "
158 inherit image
159
160 # perform some convenience tweaks to the rootfs
161 fso_rootfs_postprocess() {
162     curdir=$PWD
163     cd ${IMAGE_ROOTFS}
164     # date/time
165     date "+%m%d%H%M%Y" >./etc/timestamp
166     # alias foo
167     echo "alias pico=nano" >>./etc/profile
168     echo "alias ipkg='opkg'" >>./etc/profile
169     # dns
170     echo "nameserver 208.67.222.222" >>./etc/resolv.conf
171     echo "nameserver 208.67.220.220" >>./etc/resolv.conf
172     # nfs
173     mkdir -p ./local/pkg
174     echo >>./etc/fstab
175 #    echo "# NFS Host" >>./etc/fstab
176 #    echo "192.168.0.200:/local/pkg /local/pkg nfs noauto,nolock,soft,rsize=32768,wsize=32768 0 0" >>./etc/fstab
177     # fix .desktop files for illume
178     desktop=`find ./usr/share/applications -name "*.desktop"`
179     for file in $desktop; do
180         echo "Categories=Office;" >>$file
181     done
182     # minimal gtk theme foo
183     mkdir -p ./etc/gtk-2.0/
184     echo 'gtk-font-name = "Sans 5"' >> ./etc/gtk-2.0/gtkrc
185     cd $curdir
186 }
187
188 ROOTFS_POSTPROCESS_COMMAND += "fso_rootfs_postprocess"