gpe-image: figment is unfetchable, punt it from the image
[openembedded.git] / recipes / images / gpe-image.bb
1 LICENSE = "MIT"
2
3 # Set some defaults
4
5 MACHINE_TASK_PROVIDER = "task-base-extended"
6 GUI_MACHINE_CLASS ?= "none"
7 XSERVER ?= "xserver-kdrive-fbdev"
8 GPE_EXTRA_THEMES = "gpe-theme-industrial"
9
10 # Select bootsplash 
11 SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-angstrom", "",d)}'
12
13 # Select some useful things depending on the device capabilities
14
15 GPE_EXTRA_INSTALL_none = ""
16 GPE_EXTRA_INSTALL_bigscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
17 GPE_EXTRA_INSTALL_smallscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
18
19 GPE_EXTRA_INSTALL += "${GPE_EXTRA_INSTALL_${GUI_MACHINE_CLASS}}"
20
21 #ship more stuff with devices with >16MB of flash
22 GPE_BIGFLASH_INSTALL := '${@base_conditional("ROOT_FLASH_SIZE", "16", "", "\
23     task-gpe-connectivity \
24     gpe-theme-clearlooks \
25 ",d)}'
26
27 GPE_EXTRA_INSTALL += "${GPE_BIGFLASH_INSTALL}"
28
29
30 DEPENDS = "${MACHINE_TASK_PROVIDER} \
31            ${SPLASH} \
32            task-gpe-base \
33            task-gpe-apps \
34            task-gpe-pim \
35            task-gpe-settings \
36            task-gpe-games \
37            virtual/xserver"
38
39 IMAGE_INSTALL = "\
40     ${MACHINE_TASK_PROVIDER} \
41     task-gpe-base \
42     task-gpe-pim \
43     task-gpe-settings \
44     task-gpe-apps \
45     ${XSERVER} \
46     ${SPLASH} \
47     ${GPE_EXTRA_INSTALL}"
48
49 ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
50 ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "demo", "set_image_autologin; ", "",d)}'
51
52 inherit image