gnome-system-monitor: add 2.28.1
[openembedded.git] / recipes / hplip / hplip_2.8.10.bb
1 DESCRIPTION = "HP Linux Imaging and Printing"
2 LICENSE = "GPL, MIT"
3
4 # currently, we build a stripped down version that only includes IJS
5 # and components required to implement a minimal printing system
6 # for embedded systems.
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
9            file://cross-build.patch;patch=1"
10
11 PR = "r1"
12
13 inherit autotools
14
15 EXTRA_OECONF = ' \
16                 BUILD_SYS="" HOST_SYS="" \
17                 --disable-network-build \
18                 --disable-doc-build \
19                 --disable-pp-build \
20                 --disable-scan-build \
21                 --disable-gui-build \
22                 --disable-fax-build \
23                 --disable-dbus-build \
24                 --disable-foomatic-drv-install \
25                 --disable-foomatic-rip-hplip-install \
26                '
27
28 # needed by python checks in configure
29 EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
30
31 PACKAGES += "${PN}-ppd ${PN}-cups ${PN}-backend"
32
33 # need to snag the debug file or OE will fail on backend package
34 FILES_${PN}-dbg += "\
35      ${libdir}/cups/backend/.debug
36
37 FILES_${PN}-ppd = "\
38      ${datadir}/ppd"
39
40 FILES_${PN}-cups = "\
41      ${datadir}/cups"
42
43 FILES_${PN}-backend = "\
44      ${libdir}/cups/backend"
45