hostap-daemon-0.6.9: add patch to use LDFLAGS (fixes QA error)
[openembedded.git] / recipes / hostap / hostap-daemon_0.6.9.bb
1 DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
2 HOMEPAGE = "http://hostap.epitest.fi"
3 SECTION = "kernel/userland"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "libnl openssl"
7 PR = "r2"
8
9 DEFAULT_PREFERENCE = "-1"
10
11 SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
12         file://ldflags.patch;patch=1 \
13         file://defconfig \
14         file://init"
15
16 S = "${WORKDIR}/hostapd-${PV}/hostapd"
17
18 inherit update-rc.d
19 INITSCRIPT_NAME=hostapd
20
21 do_configure() {
22         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
23 }
24
25 do_compile() {
26         make
27 }
28
29 do_install() {
30         install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
31         install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir}
32         install -m 0755 ${S}/hostapd ${D}${sbindir}
33         install -m 0755 ${S}/hostapd_cli ${D}${sbindir}
34         install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
35 }
36