Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / hostap / hostap-daemon_0.6.9.bb
1 DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
2 HOMEPAGE = "http://hostap.epitest.fi"
3 SECTION = "kernel/userland"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "libnl openssl"
7 PR = "r1"
8
9 DEFAULT_PREFERENCE = "-1"
10
11 SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
12         file://defconfig \
13         file://init"
14
15 S = "${WORKDIR}/hostapd-${PV}/hostapd"
16
17 inherit update-rc.d
18 INITSCRIPT_NAME=hostapd
19
20 do_configure() {
21         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
22 }
23
24 do_compile() {
25         make
26 }
27
28 do_install() {
29         install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
30         install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir}
31         install -m 0755 ${S}/hostapd ${D}${sbindir}
32         install -m 0755 ${S}/hostapd_cli ${D}${sbindir}
33         install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
34 }
35