virtual/gail: Introduction of new virtual:
[openembedded.git] / recipes / gtk+ / gtk+_2.10.14.bb
1 require gtk-2.10.inc
2
3 PR = "r9"
4
5 SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
6            file://no-xwc.patch;patch=1 \
7            file://automake-lossage.patch;patch=1 \
8            file://disable-tooltips.patch;patch=1 \
9            file://gtklabel-resize-patch;patch=1 \
10            file://menu-deactivate.patch;patch=1 \
11            file://xsettings.patch;patch=1 \
12            file://scroll-timings.patch;patch=1 \
13            file://small-gtkfilesel.patch;patch=1 \
14            file://small-gtkfilechooser.patch;patch=1 \
15 #           file://migration.patch;patch=1;pnum=0 \
16            file://run-iconcache.patch;patch=1 \
17            file://hardcoded_libtool.patch;patch=1 \
18            file://no-demos.patch;patch=1 \
19            file://single-click.patch;patch=1 \
20            file://spinbutton.patch;patch=1 \
21            file://gtk+-handhelds.patch;patch=1 \
22            file://filesel-fix-segfault.patch;patch=1 \
23            file://combo-arrow-size.patch;patch=1;pnum=0 \
24            file://range-no-redraw.patch;patch=1;pnum=0 \
25            file://scrolled-placement.patch;patch=1;pnum=0 \
26            file://treeview-checkbox-size.patch;patch=1;pnum=0 \
27            file://cell-renderer-edit-focus.patch;patch=1;pnum=0 \
28            "
29
30 # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
31 require gtk-fpu.inc
32 EXTRA_OECONF += "${@get_gtk_fpu_setting(bb, d)}"
33