virtual/gail: Introduction of new virtual:
[openembedded.git] / recipes / gtk+ / gtk+-native-1.2_1.2.10.bb
1 DESCRIPTION = "GTK+1.2 is a deprecated library provided for running programs not yet converted to GTK+2.0"
2 HOMEPAGE = "http://www.gtk.org"
3 SECTION = "libs"
4 LICENSE = "LGPL"
5 PRIORITY = "optional"
6 DEPENDS = "glib-1.2 jpeg libpng libxext"
7
8 PR = "r1"
9
10 FILESPATH =+ "${FILE_DIRNAME}/gtk+-1.2-1.2.10:"
11 SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v1.2/gtk+-${PV}.tar.gz \
12            file://gtk+1.2-reconf-fix;patch=1 \
13            file://no-xwc;patch=1"
14 S = "${WORKDIR}/gtk+-${PV}"
15
16 inherit autotools pkgconfig flow-lossage
17
18 do_configure_prepend() {
19         install -d m4
20         rm -f ltconfig libtool ltmain.sh
21         libtoolize --force
22 }
23
24 FILES_${PN} += "${datadir}/themes"
25 FILES_${PN}-dev += "${datadir}/gtk-1.2/include ${libdir}/gtk-1.2/include"
26
27
28 EXTRA_OECONF = "--enable-debug=no --disable-glibtest --disable-xim"
29 # --disable-cruft
30
31 LIBV = "1.2.10"
32
33 gtk_include = "fnmatch.h gtk.h gtkaccelgroup.h gtkaccellabel.h gtkadjustment.h gtkalignment.h gtkarg.h gtkarrow.h gtkaspectframe.h gtkbbox.h gtkbin.h gtkbindings.h gtkbox.h gtkbutton.h gtkcalendar.h gtkcheckbutton.h gtkcheckmenuitem.h gtkclist.h gtkcolorsel.h gtkcombo.h gtkcompat.h gtkcontainer.h gtkctree.h gtkcurve.h gtkdata.h gtkdebug.h gtkdialog.h gtkdnd.h gtkdrawingarea.h gtkeditable.h gtkentry.h gtkenums.h gtkeventbox.h gtkfeatures.h gtkfilesel.h gtkfixed.h gtkfontsel.h gtkframe.h gtkgamma.h gtkgc.h gtkhandlebox.h gtkhbbox.h gtkhbox.h gtkhpaned.h gtkhruler.h gtkhscale.h gtkhscrollbar.h gtkhseparator.h gtkimage.h gtkinputdialog.h gtkintl.h gtkinvisible.h gtkitem.h gtkitemfactory.h gtklabel.h gtklayout.h gtklist.h gtklistitem.h gtkmain.h gtkmarshal.h gtkmenu.h gtkmenubar.h gtkmenufactory.h gtkmenuitem.h gtkmenushell.h gtkmisc.h gtknotebook.h gtkobject.h gtkoptionmenu.h gtkpacker.h gtkpaned.h gtkpixmap.h gtkplug.h gtkpreview.h gtkprivate.h gtkprogress.h gtkprogressbar.h gtkradiobutton.h gtkradiomenuitem.h gtkrange.h gtkrc.h gtkruler.h gtkscale.h gtkscrollbar.h gtkscrolledwindow.h gtkselection.h gtkseparator.h gtksignal.h gtksocket.h gtkspinbutton.h gtkstatusbar.h gtkstyle.h gtktable.h gtktearoffmenuitem.h gtktext.h gtkthemes.h gtktipsquery.h gtktogglebutton.h gtktoolbar.h gtktooltips.h gtktree.h gtktreeitem.h gtktypebuiltins.h gtktypeutils.h gtkvbbox.h gtkvbox.h gtkviewport.h gtkvpaned.h gtkvruler.h gtkvscale.h gtkvscrollbar.h gtkvseparator.h gtkwidget.h gtkwindow.h makeenums.h stamp-gtkmarshal.h stamp-gtktypebuiltins.h"
34 gdk_include = "MwmUtil.h gdk.h gdkcursors.h gdki18n.h gdkinput.h gdkinputcommon.h gdkinputgxi.h gdkinputnone.h gdkinputxfree.h gdkkeysyms.h gdkprivate.h gdkrgb.h gdktypes.h gdkx.h gxid_lib.h gxid_proto.h"
35
36 do_stage () {
37         oe_libinstall -so -C gtk libgtk-1.2 ${STAGING_LIBDIR}
38         oe_libinstall -so -C gdk libgdk-1.2 ${STAGING_LIBDIR}
39
40         mkdir -p ${STAGING_INCDIR}/gtk-1.2/gtk
41         for i in ${gtk_include}; do
42                 install -m 0644 gtk/$i ${STAGING_INCDIR}/gtk-1.2/gtk/$i
43         done
44
45         mkdir -p ${STAGING_INCDIR}/gtk-1.2/gdk
46         for i in ${gdk_include}; do
47                 install -m 0644 gdk/$i ${STAGING_INCDIR}/gtk-1.2/gdk/$i
48         done
49
50         mkdir -p ${STAGING_LIBDIR}/gtk-1.2/include
51
52         install -m 0644 gtk.m4 ${STAGING_DATADIR}/aclocal/
53 }
54
55 do_install_append () {
56         install -d ${D}${sysconfdir}/gtk-1.2
57 }
58