gtk+: reinstate no-demos patch for gtk+-native, it fails to build without it
[openembedded.git] / recipes / gtk+ / composite-pixbuf_0.0.bb
1 DESCRIPTION = "Pixbuf performance test"
2 LICENSE = "Public domain"
3 DEPENDS = "gtk+" 
4
5 SRC_URI = "http://amelang.net/composite_pixbuf.c"
6
7 S = "${WORKDIR}"
8
9 do_compile() {
10         ${CC} ${CFLAGS} composite_pixbuf.c -o composite_pixbuf \
11             `pkg-config --cflags gdk-2.0` `pkg-config --libs gdk-2.0` `pkg-config --libs x11` `pkg-config --libs pango` \
12              -lxcb -lXext -lXinerama -lXrandr -lXcursor -lXfixes -lpangoft2-1.0 -lz -lexpat -lxcb-xlib -lXau -lXdmcp  
13 }           
14
15 do_install() {
16         install -d ${D}${bindir} 
17         install -m 755 composite_pixbuf ${D}${bindir}
18 }