Updated some recipes
[openembedded.git] / recipes / gstreamer / gst-plugins-ugly_0.10.15.bb
1 require gst-plugins.inc
2
3 PR = "${INC_PR}.0"
4
5 DEPENDS += "gst-plugins-base mpeg2dec libsidplay"
6
7 SRC_URI += "\
8   file://gstmad_16bit.patch \
9   file://gstsid_autofoo_HACK.patch \
10 "
11 SRC_URI[archive.md5sum] = "21c034a762a5da252f91640e53bfe457"
12 SRC_URI[archive.sha256sum] = "ceebb7878d957a61cf437c1f93934a0371631fa50e4111ef016691d65866790c"
13
14 python() {
15         # Don't build, if we are building an ENTERPRISE distro
16         enterprise = bb.data.getVar("ENTERPRISE_DISTRO", d, 1)
17         if enterprise == "1":
18                 raise bb.parse.SkipPackage("gst-plugins-ugly will only build if ENTERPRISE_DISTRO != 1")
19 }
20