Updated some recipes
[openembedded.git] / recipes / gstreamer / gst-plugins-ugly-sid_0.10.7.bb
1 require gst-plugins.inc
2 DEPENDS += "gst-plugins-base libsidplay"
3 PROVIDES += "gst-plugin-sid"
4
5 PR = "${INC_PR}.1"
6
7 SRC_URI = "\
8   http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-${PV}.tar.bz2 \
9   file://gstsid_autofoo_HACK.patch \
10 "
11 S = "${WORKDIR}/gst-plugins-ugly-${PV}"
12
13 python() {
14     # Don't build, if we are building an ENTERPRISE distro
15     enterprise = bb.data.getVar("ENTERPRISE_DISTRO", d, 1)
16     if enterprise != "1":
17             raise bb.parse.SkipPackage("gst-plugins-ugly-sid will only build if ENTERPRISE_DISTRO == 1")
18 }
19
20 SRC_URI[md5sum] = "cff4f55138d12152cf580a3ee71c2519"
21 SRC_URI[sha256sum] = "556ba24072bdb32ee568adc682d69add1241d77936bc9563e50cdb953097be35"