libgcrypt: update to 1.4.6
[openembedded.git] / recipes / gstreamer / gst-plugins-base_0.10.32.bb
1 require gst-plugins.inc
2
3 SRC_URI += " \
4             file://ivorbis-thumb.patch;patch=1 \
5 "
6
7 SRC_URI[archive.md5sum] = "2920af2b3162f3d9fbaa7fabc8ed4d38"
8 SRC_URI[archive.sha256sum] = "e9aabfac83f6480896da0686e9c911989f896fbad634821b7771ed84a446172b"
9
10 PR = "${INC_PR}.1"
11
12 PROVIDES += "gst-plugins"
13
14 # gst-plugins-base only builds the alsa plugin
15 # if alsa has been built and is present.  You will
16 # not get an error if this is not present, just
17 # a missing alsa plugin
18 DEPENDS += "udev cdparanoia pango libtheora alsa-lib libsm virtual/libx11 freetype  libxv libxrandr gtk+"
19
20 def get_gstreamer_fpu_setting(bb, d):
21     if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
22         return "--with-audioresample-format=int"
23     return ""
24
25 # Needs a udev that enabled gudev, which isn't the default
26 EXTRA_OECONF += "--with-gudev --disable-gnome_vfs ${@get_gstreamer_fpu_setting(bb, d)}"
27
28 do_configure_prepend() {
29         sed -i -e s:QtGui:NoQtGui:g ${S}/configure.ac
30 }
31
32 PACKAGES_DYNAMIC = "\
33 gst-plugin-adder* \
34 gst-plugin-alsa* \
35 gst-plugin-app* \
36 gst-plugin-audioconvert* \
37 gst-plugin-audiorate* \
38 gst-plugin-audioresample* \
39 gst-plugin-audiotestsrc* \
40 gst-plugin-cdparanoia* \
41 gst-plugin-decodebin2* \
42 gst-plugin-decodebin* \
43 gst-plugin-encodebin* \
44 gst-plugin-ffmpegcolorspace* \
45 gst-plugin-gdp* \
46 gst-plugin-gio* \
47 gst-plugin-ivorbisdec* \
48 gst-plugin-libvisual* \
49 gst-plugin-ogg* \
50 gst-plugin-pango* \
51 gst-plugin-playbin* \
52 gst-plugin-subparse* \
53 gst-plugin-tcp* \
54 gst-plugin-theora* \
55 gst-plugin-typefindfunctions* \
56 gst-plugin-video4linux* \
57 gst-plugin-videorate* \
58 gst-plugin-videoscale* \
59 gst-plugin-videotestsrc* \
60 gst-plugin-volume* \
61 gst-plugin-vorbis* \
62 gst-plugin-ximagesink* \
63 gst-plugin-xvimagesink* \
64 "