Updated some recipes
[openembedded.git] / recipes / gstreamer / gst-plugin-pulse_0.9.7.bb
1 DESCRIPTION = "GStreamer plugin for using pulse audio as sink and source"
2 HOMEPAGE = "http://0pointer.de/lennart/projects/gst-pulse/"
3 LICENSE = "GPL"
4 DEPENDS = "gstreamer pulseaudio gst-plugins-base"
5 PR = "r1"
6
7 SRC_URI = "http://0pointer.de/lennart/projects/gst-pulse/gst-pulse-${PV}.tar.gz \
8         file://dont-overload-pulseaudio.patch"
9 S = "${WORKDIR}/gst-pulse-${PV}"
10
11 inherit autotools
12
13 EXTRA_OECONF = "--disable-lynx"
14 GST_LIBV = 0.10
15
16 do_install() {
17         install -d ${D}${libdir}/gstreamer-${GST_LIBV}/
18         install -m 0755 src/.libs/libgstpulse.so ${D}${libdir}/gstreamer-${GST_LIBV}
19 }
20
21 export GST_MODDIR=${libdir}/gstreamer-0.10
22
23 FILES_${PN} = "${libdir}/gstreamer-0.10/libgstpulse.so"
24 FILES_${PN}-dev = "\
25   ${libdir}/gstreamer-0.10/libgstpulse.a \
26   ${libdir}/gstreamer-0.10/libgstpulse.la \
27   ${libdir}/gstreamer-0.10/libgstpulse.so*"
28 FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
29
30
31 SRC_URI[md5sum] = "166164eb07eacd1d70b965731eb6cbdb"
32 SRC_URI[sha256sum] = "b9f1bb98917d9879d46b6a959ce9068471908763f2ca98e480837485e290b106"