util-linux-ng: fix swaponoff
[openembedded.git] / recipes / gpe-mini-browser / gpe-mini-browser_svn.bb
1 DEPENDS = "sqlite gettext gtk+ glib-2.0 osb-nrcit libgpewidget"
2 RRECOMMENDS = "gdk-pixbuf-loader-gif gdk-pixbuf-loader-png gdk-pixbuf-loader-jpeg"
3
4 SRCREV = "9900"
5 PV = "0.20+svn${SRCDATE}"
6 PR = "r0"
7
8 inherit autotools
9
10 SRC_URI = "${GPE_EXTRA_SVN}"
11
12 S = "${WORKDIR}/gpe-mini-browser"
13
14 do_install() {
15                 install -d ${D}/usr/share/applications
16                 install -m 0644 ${S}/gpe-mini-browser.desktop ${D}/usr/share/applications/gpe-mini-browser.desktop
17                 install -d ${D}/usr/share/pixmaps
18                 install -m 0644 ${S}/gpe-mini-browser.png ${D}/usr/share/pixmaps/gpe-mini-browser.png
19                 autotools_do_install
20 }
21
22 pkg_postinst_${PN}-doc () {
23         #!/bin/sh
24         if [ "x$D" != "x" ]; then
25         if [ -e /etc/gpe/gpe-help.conf ]; then
26                 echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
27         else
28                  echo [Help] >> /etc/gpe/gpe-help.conf
29                  echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
30         fi
31         if [ -x /usr/bin/gpe-helpindex ]; then
32                 echo generating help-index
33                 gpe-helpindex
34         else
35                 echo not generating index for gpe-mini-browser
36         fi
37         fi
38 }
39 pkg_postrm_${PN}-doc () {
40         #!/bin/sh
41         if [ -e /etc/gpe/gpe-help.conf ]; then
42                 sed '/^\<gpe-mini-browser\>/d' /etc/gpe/gpe-help.conf > /tmp/gpe-help.conf
43                 mv /tmp/gpe-help.conf /etc/gpe/gpe-help.conf
44         fi
45         if [ -x /usr/bin/gpe-helpindex ]; then
46                 echo generating help-index
47                 gpe-helpindex
48         else
49                 echo not generating index for gpe-mini-browser
50         fi
51 }
52
53 require gpe-mini-browser.inc
54
55 #DEFAULT_PREFERENCE = "-1"