Merge branch 'org.openembedded.dev' of git+ssh://git@git.openembedded.org/openembedde...
[openembedded.git] / recipes / gpe-mini-browser / gpe-mini-browser_0.17.bb
1 require gpe-mini-browser.inc
2
3 SRC_URI = "ftp://ftp.handhelds.org/projects/gpe/source/gpe-mini-browser-${PV}.tar.gz"
4 DEPENDS = "osb-nrcit sqlite libgpewidget"
5 RRECOMMENDS = "gdk-pixbuf-loader-gif gdk-pixbuf-loader-png gdk-pixbuf-loader-jpeg"
6
7
8 S = "${WORKDIR}/gpe-mini-browser-${PV}"
9
10 inherit autotools
11
12 do_install() {
13                 install -d ${D}/usr/share/applications
14                 install -m 0644 ${S}/gpe-mini-browser.desktop ${D}/usr/share/applications/gpe-mini-browser.desktop
15                 install -d ${D}/usr/share/pixmaps
16                 install -m 0644 ${S}/gpe-mini-browser.png ${D}/usr/share/pixmaps/gpe-mini-browser.png
17                 autotools_do_install
18 }
19
20 pkg_postinst_${PN}-doc () {
21         #!/bin/sh
22         if [ "x$D" != "x" ]; then
23         if [ -e /etc/gpe/gpe-help.conf ]; then
24                 echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
25         else
26                  echo [Help] >> /etc/gpe/gpe-help.conf
27                  echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
28         fi
29         if [ -x /usr/bin/gpe-helpindex ]; then
30                 echo generating help-index
31                 gpe-helpindex
32         else
33                 echo not generating index for gpe-mini-browser
34         fi
35         fi
36 }
37
38 pkg_postrm_${PN}-doc () {
39         #!/bin/sh
40         if [ -e /etc/gpe/gpe-help.conf ]; then
41                 sed '/^\<gpe-mini-browser\>/d' /etc/gpe/gpe-help.conf > /tmp/gpe-help.conf
42                 mv /tmp/gpe-help.conf /etc/gpe/gpe-help.conf
43         fi
44         if [ -x /usr/bin/gpe-helpindex ]; then
45                 echo generating help-index
46                 gpe-helpindex
47         else
48                 echo not generating index for gpe-mini-browser
49         fi
50 }
51