Merge branch 'org.openembedded.dev' of git+ssh://git@git.openembedded.org/openembedde...
[openembedded.git] / recipes / gpe-mini-browser / gpe-mini-browser-hildon_0.17.bb
1 require gpe-mini-browser.inc
2
3 PR = "r0"
4
5 SRC_URI      = "${GPE_MIRROR}/gpe-mini-browser-${PV}.tar.gz"
6 DESCRIPTION  = "A lightweight webbrowser for the GPE platform (Hildon UI)"
7 DEPENDS      = "osb-nrcit libosso hildon-lgpl hildon-fm libgpewidget"
8 EXTRA_OECONF = "--enable-hildon"
9
10 S = "${WORKDIR}/gpe-mini-browser-${PV}"
11
12 inherit autotools
13
14 do_install() {
15                 install -d ${D}/usr/share/applications/hildon
16                 install -m 0644 ${S}/hildon/gpe-mini-browser.desktop ${D}/usr/share/applications/hildon/gpe-mini-browser.desktop
17                 install -d ${D}/usr/share/pixmaps
18                 install -m 0644 ${S}/gpe-mini-browser.png ${D}/usr/share/pixmaps/gpe-mini-browser.png
19                 autotools_do_install
20 }
21
22