utils.bbclass: restore previous implementation of explode_deps()
[openembedded.git] / recipes / gnuchess / gnuchess_5.021.bb
1 DESCRIPTION = "Gnuchess is a chess playing engine."
2 SECTION = "console"
3 PRIORITY = "optional"
4 MAINTAINER = "Andreas Holzer <a.holzer@cheese.at>"
5 LICENSE = "GPL"
6 PR = "r1"
7 RSUGGESTS_${PN} = "xboard"
8 SRC_URI = "http://members.cheese.at/woody/fltk-chess/gnuchess_5.02.tar.gz \
9            file://gnuchess.desktop \
10            file://gnuchess.png \
11            file://gnuchess.sh \
12
13 S = "${WORKDIR}/chess-5.02/src"
14
15 inherit autotools
16
17 do_install() {
18         install -d ${D}${bindir}
19         install -d ${D}${datadir}/pixmaps/
20         install -d ${D}${datadir}/applications/
21         install -m 0755 ${WORKDIR}/gnuchess.sh ${D}${bindir}
22         install -m 0644 ${WORKDIR}/gnuchess.png  ${D}${datadir}/pixmaps/
23         install -m 0644 ${WORKDIR}/gnuchess.desktop  ${D}${datadir}/applications/
24         install -D ${S}/gnuchess ${D}${bindir}/gnuchess
25 }