Updated some recipes
[openembedded.git] / recipes / gnu-config / gnu-config_git.bb
1 DESCRIPTION = "The GNU config.guess and config.sub scripts"
2 SECTION = "base"
3 LICENSE = "GPL"
4 DEPENDS = ""
5 INHIBIT_DEFAULT_DEPS = "1"
6
7 PR = "r0"
8 FAKESRCREV="e35217687ee5f39b428119fe31c7e954f6de64f0"
9 PR_append = "+gitr${FAKESRCREV}"
10
11 SRC_URI = "http://www.angstrom-distribution.org/unstable/sources/git_git.savannah.gnu.org.config.git_${FAKESRCREV}.tar.gz \
12            file://config-guess-uclibc.patch \
13            file://gnu-configize.in"
14
15 SRC_URI[md5sum] = "6a45979aa33d15b23c874b95e24c8732"
16 SRC_URI[sha256sum] = "a83bf7c7c972eb4106b5d7c6126d3b5b058f7aace7a62cae4e4f330d62f40259"
17
18 S = "${WORKDIR}/git"
19
20 do_compile() {
21         :
22 }
23
24 do_install () {
25         install -d ${D}${datadir}/gnu-config \
26                    ${D}${bindir}
27         cat ${WORKDIR}/gnu-configize.in | \
28                 sed -e 's,@gnu-configdir@,${datadir}/gnu-config,g' \
29                     -e 's,@autom4te_perllibdir@,${datadir}/autoconf,g' > ${D}${bindir}/gnu-configize
30         # In the native case we want the system perl as perl-native can't have built yet
31         if [ "${BUILD_ARCH}" != "${TARGET_ARCH}" ]; then
32                 cat ${WORKDIR}/gnu-configize.in | \
33                         sed -e 's,/usr/bin/perl,${bindir}/perl,g' > ${D}${bindir}/gnu-configize
34         fi
35         chmod 755 ${D}${bindir}/gnu-configize
36         install -m 0644 config.guess config.sub ${D}${datadir}/gnu-config/
37 }
38
39 FILES_${PN} = "${bindir} ${datadir}/gnu-config"
40
41 BBCLASSEXTEND = "native"
42 NATIVE_INSTALL_WORKS = "1"
43