3a1e12dfe565ff04f74436151da21a1748b9ac7b
[openembedded.git] / recipes / gnome / gnome-keyring_2.28.2.bb
1 DESCRIPTION = "GNOME security credential management"
2 LICENSE = "GPL"
3 SECTION = "x11/gnome"
4 DEPENDS = " gtk+-native libpam gconf gtk+ libtasn1 libtasn1-native libgcrypt"
5 PR = "r1"
6
7 inherit gnome pkgconfig
8
9 EXTRA_OECONF = "--disable-gtk-doc --enable-pam --with-pam-dir=${libdir}/security"
10
11 SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service file://libtool.workarround.patch;patch=1"
12
13 do_configure_prepend() {
14         cp ${WORKDIR}/tasn.m4 acinclude.m4
15 }
16
17 do_install_append () {
18         install -d ${D}${datadir}/dbus-1/services
19         install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
20 }
21
22 FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr"
23 PACKAGES =+ "gnome-keyring-pam-plugin"
24 FILES_gnome-keyring-pam-plugin = "${libdir}/security/*.so"
25 FILES_${PN}-dbg += "${libdir}/gnome-keyring/*/.debug ${libdir}/security/.debug"
26