Updated some recipes
[openembedded.git] / recipes / gnome / gnome-keyring_2.26.0.bb
1 LICENSE = "GPL"
2 SECTION = "x11/gnome"
3
4 inherit autotools gnome pkgconfig
5
6 DEPENDS = " libpam gconf gtk+ libtasn1 libtasn1-native libgcrypt"
7
8 EXTRA_OECONF = "--disable-gtk-doc"
9
10 SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service"
11
12 do_configure_prepend() {
13         cp ${WORKDIR}/tasn.m4 acinclude.m4
14 }
15
16 do_install_append () {
17         install -d ${D}${datadir}/dbus-1/services
18         install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
19 }
20
21 FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr"
22 PACKAGES =+ "gnome-keyring-pam-plugin"
23 FILES_gnome-keyring-pam-plugin = "${libdir}/security/*.so"
24 FILES_${PN}-dbg += "${libdir}/gnome-keyring/*/.debug ${libdir}/security/.debug"
25
26 SRC_URI[archive.md5sum] = "0395fcf79b990465030a2795dcddacb9"
27 SRC_URI[archive.sha256sum] = "7acda11db2eb07b2f68a1a506203fe95141954acb10c394850418fd04ed80a07"