xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / recipes / gnome / gnome-bluetooth_git.bb
1 LICENSE = "GPL"
2 SECTION = "x11/gnome"
3
4 DEFAULT_PREFERENCE = "-1"
5 DEFAULT_PREFERENCE_angstrom = "1"
6
7 inherit autotools gnome pkgconfig
8
9 SRC_URI = "git://git.gnome.org/gnome-bluetooth;branch=gnome-2-28;protocol=git \
10            file://gtk-doc.make \
11 "
12
13 S = "${WORKDIR}/git"
14
15 SRCREV = "2d23ec20fa8f8299e93beea849bc8670aa2c7c69"
16 PV = "2.28.6"
17 PR = "r0"
18 PR_append = "+gitr${SRCREV}"
19
20 DEPENDS = "geoclue obexd gconf gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring"
21 RRECOMMENDS_${PN} += "obexd"
22 RCONFLICTS_${PN} = "bluez-gnome"
23
24 do_configure_prepend() {
25         cp ${WORKDIR}/gtk-doc.make ${S}/
26         sed -i -e s:docs::g ${S}/Makefile.am
27         sed -i -e s:gnome-bluetooth/plugins/:gnome-bluetooth/plugins:g ${S}/lib/plugins/Makefile.am
28         echo "EXTRA_DIST = version.xml" > gnome-doc-utils.make
29 }
30
31 # Todo: automagic plugin splitting
32
33 FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug"