libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / gdb / gdb-cross_6.7.1.bb
1 require gdb-cross.inc
2 LICENSE = "GPLv3"
3
4 inherit cross
5
6 DEFAULT_PREFERENCE_avr32 = "99"
7 SRC_URI_avr32 = " http://avr32linux.org/twiki/pub/Main/GDBPatches/gdb-6.7.1.atmel.1.0.3.tar.bz2"
8 S_avr32 = "${WORKDIR}/gdb-6.7.1.atmel.1.0.3"
9
10 do_configure_prepend() {
11     for i in $(find ${S} -name "warning*m4") ; do
12         sed -i -e s:-Werror::g $i
13     done
14     for i in $(find ${S} -name "configure.ac") ; do
15         sed -i -e s:-Werror::g $i
16     done
17     for i in $(find ${S} -name "configure") ; do
18         sed -i -e s:-Werror::g $i
19     done
20 }
21