libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / freedoom / freedoom_0.3.bb
1 SECTION = "games"
2 DESCRIPTION = "The Freedoom project aims at collaboratively creating a Free IWAD file.\
3                Combined with the Free source code, this results in a complete game \
4                based on the Doom engine which is Free Software."
5 HOMEPAGE = "http://freedoom.sourceforge.net/"
6 PRIORITY = "optional"
7 LICENSE = "GPL"
8 do_unpack[depends] += "unzip-native:do_populate_staging"
9
10 SRC_URI = "http://ovh.dl.sourceforge.net/sourceforge/freedoom/freedoom-iwad-0.3.zip"
11
12 PR = "r1"
13
14 FILES_${PN} = "/usr/share/games/doom/*"
15 FILES_${PN}-doc = "/usr/share/doc/freedoom/*"
16
17 do_install() {
18         install -d ${D}/usr/share/games/doom
19         install -d ${D}/usr/share/doc/freedoom
20
21         install -m 0644 ${WORKDIR}/freedoom-iwad-${PV}/doom2.wad ${D}/usr/share/games/doom/
22         install -m 0644 ${WORKDIR}/freedoom-iwad-${PV}/* ${D}/usr/share/doc/freedoom
23         rm ${D}/usr/share/doc/freedoom/*.wad
24
25
26
27
28 }
29