util-linux-ng: fix swaponoff
[openembedded.git] / recipes / ezx / ezxd_svn.bb
1 DESCRIPTION = "Open implementation of motorola's tapisrv, replaces opentapi"
2 LICENSE = "GPLv2"
3 SECTION = "devel"
4 AUTHOR = "Daniel Ribeiro"
5
6 SRCREV = "2513"
7 PV = "0.0+svnr${SRCPV}"
8 PR = "r4"
9
10 SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=ezxd;proto=http \
11            file://ezxd.init \
12           "
13
14 inherit update-rc.d
15
16 INITSCRIPT_NAME = "ezxd"
17 INITSCRIPT_PARAMS = "start 00 S ."
18
19 S = "${WORKDIR}/${PN}"
20
21 CFLAGS_append = " -DDEBUG " 
22
23 TARGET_CC_ARCH += "${LDFLAGS}"
24
25 do_configure() {
26         # Comment out both CC and CROSS definitions
27         sed -i -e 's:^CC.*$:#\0:g' Makefile
28         sed -i -e 's:^CROSS.*$:#\0:g' Makefile
29 }
30
31 fakeroot do_install() {
32         install -d ${D}/dev/input
33         mknod ${D}/dev/input/uinput c 10 223
34
35         install -d ${D}${bindir}
36         install -m 755 ezxd ${D}${bindir}
37
38         install -d ${D}${libdir}/ezxd
39         install -m 755 *.so ${D}${libdir}/ezxd
40
41         install -d ${D}${sysconfdir}/init.d
42         install -m 0600 ezxd.conf ${D}${sysconfdir}/
43         install -m 0755 ${WORKDIR}/ezxd.init ${D}${sysconfdir}/init.d/ezxd
44 }
45
46 FILES_${PN} += "/dev"
47 CONFFILES_${PN} += "${sysconfdir}/ezxd.conf"
48