libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / espeak / espeak_1.37.bb
1 require espeak.inc
2 inherit siteinfo
3
4 EXTRA_PHONEMES = '${@base_contains("SITEINFO_ENDIANESS", "be",  "espeak-data (= ${PV})", "", d)}'
5 RDEPENDS_${PN} = "portaudio-v19 ${EXTRA_PHONEMES}"
6
7 PR = "r0"
8
9 CXXFLAGS += "-DUSE_PORTAUDIO"
10 TARGET_CC_ARCH += "${LDFLAGS}"
11
12 FILES_${PN} += "${datadir}/espeak-data"
13
14 do_configure() {
15        #  "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19
16        cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
17 }
18
19 do_compile() {
20        cd src
21        oe_runmake
22 }
23
24 do_install() {
25         install -d ${D}${bindir}
26         install -d ${D}${libdir}
27         install -d ${D}${includedir}
28         install -d ${D}${datadir}/espeak-data
29
30         # we do not ship "speak" binary though.
31         install -m 0755 ${S}/src/espeak ${D}${bindir}
32         install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}
33         oe_libinstall -so -C src libespeak ${D}${libdir}
34
35         if [ "${SITEINFO_ENDIANESS}" = "be" ] ; then
36                 # the big-endian phon* files are provided by the package espeak-data
37                 rm -f ${S}/espeak-data/phon*
38         fi
39
40         cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
41 }
42
43 do_stage() {
44         install -d ${STAGING_INCDIR}/espeak
45         install -m 0644 ${S}/src/speak_lib.h ${STAGING_INCDIR}/espeak/
46         oe_libinstall -so -C src libespeak ${STAGING_LIBDIR}
47 }