Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org...
[openembedded.git] / recipes / eglibc / eglibc_svn.bb
1 require eglibc.inc
2
3 DEPENDS += "gperf-native"
4 SRCREV = "9123"
5 DEFAULT_PREFERENCE = "-1"
6 FILESPATHPKG =. "eglibc-svn:"
7 PV = "2.10+svnr${SRCREV}"
8 PR = "${INC_PR}.1"
9 EGLIBC_BRANCH="trunk"
10 SRC_URI = "svn://svn.eglibc.org;module=trunk \
11            file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
12            file://armv4t-interworking.patch;patch=1 \
13            file://etc/ld.so.conf \
14            file://generate-supported.mk"
15 S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
16 B = "${WORKDIR}/build-${TARGET_SYS}"
17
18 PACKAGES_DYNAMIC = "libc6*"
19 RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
20 PROVIDES_${PN}-dbg = "glibc-dbg"
21
22 # the -isystem in bitbake.conf screws up glibc do_stage
23 BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
24 TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
25
26 GLIBC_ADDONS ?= "ports,nptl,libidn"
27
28 GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN"
29
30 #
31 # For now, we will skip building of a gcc package if it is a uclibc one
32 # and our build is not a uclibc one, and we skip a glibc one if our build
33 # is a uclibc build.
34 #
35 # See the note in gcc/gcc_3.4.0.oe
36 #
37
38 python __anonymous () {
39     import bb, re
40     uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
41     if uc_os:
42         raise bb.parse.SkipPackage("incompatible with target %s" %
43                                    bb.data.getVar('TARGET_OS', d, 1))
44 }
45
46 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
47                 --without-cvs --disable-profile --disable-debug --without-gd \
48                 --enable-clocale=gnu \
49                 --enable-add-ons=${GLIBC_ADDONS},ports \
50                 --with-headers=${STAGING_INCDIR} \
51                 --without-selinux \
52                 ${GLIBC_EXTRA_OECONF}"
53
54 EXTRA_OECONF += "${@get_eglibc_fpu_setting(bb, d)}"
55
56 do_unpack_append() {
57         bb.build.exec_func('do_move_ports', d)
58 }
59
60 do_move_ports() {
61         if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
62             rm -rf ${S}/ports
63             mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
64         fi
65 }
66
67 do_configure () {
68 # override this function to avoid the autoconf/automake/aclocal/autoheader
69 # calls for now
70 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
71 # version check and doesn't really help with anything
72         if [ -z "`which rpcgen`" ]; then
73                 echo "rpcgen not found.  Install glibc-devel."
74                 exit 1
75         fi
76         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
77         find ${S} -name "configure" | xargs touch
78         CPPFLAGS="" oe_runconf
79 }
80
81 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
82           yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
83           rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
84
85 do_compile () {
86         # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
87         unset LDFLAGS
88         base_do_compile
89         (
90                 cd ${S}/sunrpc/rpcsvc
91                 for r in ${rpcsvc}; do
92                         h=`echo $r|sed -e's,\.x$,.h,'`
93                         rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
94                 done
95         )
96 }
97
98 require eglibc-stage.inc
99
100 require eglibc-package.bbclass