Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / efl1 / esmart_svn.bb
1 DESCRIPTION = "ESmart is a collection of smart Evas objects"
2 LICENSE = "MIT BSD"
3 DEPENDS = "evas ecore edje imlib2 epsilon libtool"
4 PV = "0.9.0.050+svnr${SRCREV}"
5 PR = "r1"
6
7 inherit efl
8
9 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
10
11 PACKAGES =+ "${PN}-textentry \
12              ${PN}-thumb \
13              ${PN}-container \
14              ${PN}-container-plugins \
15              ${PN}-file-dialog \
16              ${PN}-draggies \
17              ${PN}-trans-x11"
18
19 FILES_${PN}-dbg += "${libdir}/.debug/ ${libdir}/esmart/*/.debug/"
20 FILES_${PN}-textentry = "${libdir}/libesmart_text_entry*.so*"
21 FILES_${PN}-thumb = "${libdir}/libesmart_thumb*.so*"
22 FILES_${PN}-container = "${libdir}/libesmart_container*"
23 DEPENDS_${PN}-container += "${PN}-container-plugins"
24 FILES_${PN}-container-plugins = "${libdir}/esmart/layout/*.so"
25 FILES_${PN}-file-dialog = "${libdir}/libesmart_file_dialog*.so*"
26 FILES_${PN}-draggies = "${libdir}/libesmart_draggies*.so*"
27 FILES_${PN}-trans-x11 = "${libdir}/libesmart_trans_x11*.so*"