util-linux-ng: fix swaponoff
[openembedded.git] / recipes / dbus / dbus-native_1.0.3.bb
1 require dbus.inc
2
3 PR = "${INC_PR}.0"
4 DEFAULT_PREFERENCE = "-1"
5
6 inherit native
7
8 EXTRA_OECONF_X = "--without-x"
9
10 DEPENDS = "glib-2.0-native libxml2-native expat-native"
11 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
12
13 SRC_URI = "\
14   http://freedesktop.org/software/dbus/releases/dbus/dbus-${PV}.tar.gz \
15   file://cross.patch;patch=1 \
16   file://tmpdir.patch;patch=1 \
17   file://fedora-compile-fix.patch;patch=1 \
18   file://dbus-1.init \
19 "
20
21 do_stage() {
22         oe_runmake install
23         autotools_stage_all
24
25         # for dbus-glib-native introspection generation
26         install -d ${STAGING_DATADIR}/dbus
27         install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
28 }
29
30 do_install() {
31         :
32 }