ccache: update to 3.2.3
[openembedded.git] / recipes / dasher / dasher-gpe_0.0-svn.bb
1 LICENSE="GPL"
2 PV = "0.0+svnr${SRCPV}"
3 PR = "r1"
4 SRCREV = "1251"
5 DEPENDS = "libxsettings-client libglade libxtst gconf gtk+"
6 SECTION = "gpe"
7 SRC_URI = "svn://svn.gnome.org/svn/dasher;module=trunk \
8         file://configure-lossage.patch;patch=1"
9
10 S = "${WORKDIR}/trunk"
11 FILES_${PN} += "${datadir}/dasher"
12
13 inherit autotools
14
15
16 EXTRA_OECONF = "--with-gpe --without-gnome --without-speech --without-a11y"
17 LDFLAGS_append = '-Wl,--export-dynamic'
18
19 do_configure_prepend() {
20         rm -f m4/libtool.m4
21         intltoolize --force
22 }
23
24 do_install_append () {
25         install -d ${D}${datadir}/pixmaps/
26         mv ${D}${datadir}/icons/dasher.png ${D}${datadir}/pixmaps/
27 }
28
29 python populate_packages_prepend () {
30         do_split_packages(d, bb.data.expand("${datadir}/dasher", d), "training_(.*).txt", "dasher-training-data-%s", "Dasher training data for %s", prepend=True)
31 }
32