ccache: update to 3.2.3
[openembedded.git] / recipes / console-tools / console-tools_0.3.2.bb
1 SECTION = "base"
2 LICENSE = "GPL"
3 DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
4 PR = "r4"
5
6 SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
7            file://codepage.patch;patch=1 \
8            file://configure.patch;patch=1 \
9            file://compile.patch;patch=1 \
10            file://kbdrate.patch;patch=1 \
11            file://uclibc-fileno.patch;patch=1 \
12            file://config"
13
14 export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \
15                   examples po intl compat"
16
17 do_compile () {
18         oe_runmake -C lib
19         oe_runmake 'SUBDIRS=${SUBDIRS}'
20 }
21
22 inherit autotools gettext
23
24 acpaths = "-I ${WORKDIR}/config"
25
26 do_install () {
27         autotools_do_install
28         mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
29         mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
30         mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
31         mv ${D}${bindir}/showkey ${D}${bindir}/showkey.${PN}
32 }
33
34 pkg_postinst_${PN} () {
35         update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
36         update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
37         update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
38         update-alternatives --install ${bindir}/showkey showkey showkey.${PN} 100
39 }
40
41 pkg_prerm_${PN} () {
42         update-alternatives --remove chvt chvt.${PN}
43         update-alternatives --remove deallocvt deallocvt.${PN}
44         update-alternatives --remove openvt openvt.${PN}
45         update-alternatives --remove showkey showkey.${PN}
46 }
47