zaurus-2.6.inc: force creation of jffs2 images
[openembedded.git] / recipes / busybox / slingbox_1.3.1.bb
1 DESCRIPTION = "SlingBox is a minimal version of BusyBox with just enough functionality \
2 to enable ipkg to run on an Unslung NSLU2 device."
3 HOMEPAGE = "http://www.busybox.net"
4 LICENSE = "GPL"
5 SECTION = "base"
6 PRIORITY = "required"
7 PR = "r4"
8 COMPATIBLE_MACHINE = "nslu2"
9
10 SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
11            file://defconfig \
12            file://mountall \
13            file://shadow_h_is_required.patch;patch=1 \
14            file://df_rootfs.patch;patch=1 \
15            file://lazy_umount.patch;patch=1 \
16            file://halt.patch;patch=1 \
17            file://fdisk-readhex.patch;patch=1 \
18            file://trylink-bash.patch;patch=1 \
19            file://slingbox_name.patch;patch=1 \
20            file://slingbox.patch;patch=1"
21
22 S = "${WORKDIR}/busybox-${PV}"
23
24 export EXTRA_CFLAGS = "${CFLAGS}"
25 EXTRA_OEMAKE_append = " V=1 ARCH=arm CROSS_COMPILE=${TARGET_PREFIX}"
26
27 FILES_${PN} = "/"
28 FILES_${PN}-doc = ""
29 FILES_${PN}-dev = ""
30 FILES_${PN}-locale = ""
31
32 inherit cml1
33
34 do_configure () {
35         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
36         cml1_do_configure
37 }
38
39 do_compile () {
40         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
41         base_do_compile
42 }
43
44 do_install () {
45         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
46         oe_runmake "PREFIX=${D}" install
47
48         # Just in case fdisk is compiled in, do not overwrite the Linksys one
49         rm -f ${S}/_install/sbin/fdisk
50
51         cp -pPR ${S}/_install/* ${D}/
52 }