673fe15ba7a46135fb03b171b39ad7cedb6021b3
[openembedded.git] / recipes / busybox / busybox_1.11.3.bb
1 require busybox.inc
2 PR = "${INC_PR}.1"
3
4 SRC_URI = "\
5   http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
6   \
7   file://udhcpscript.patch;patch=1 \
8   file://B921600.patch;patch=1 \
9   file://fdisk_lineedit_segfault.patch;patch=1 \
10   file://busybox-appletlib-dependency.patch;patch=1 \
11   file://busybox-cron \
12   file://busybox-httpd \
13   file://busybox-udhcpd \
14   file://default.script \
15   file://hwclock.sh \
16   file://mount.busybox \
17   file://mountall \
18   file://syslog \
19   file://syslog.conf \
20   file://umount.busybox \
21   file://defconfig \
22   file://mdev \
23   file://mdev.conf \
24 "
25
26 EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
27
28 do_configure () {
29         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
30         cml1_do_configure
31 }
32
33 do_install_append() {
34     install -m 0644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
35     install -d ${D}${sysconfdir}/init.d/
36     install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
37 }
38