Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / bluez / bluez4_4.35.bb
1 DESCRIPTION = "Linux Bluetooth Stack Userland V4"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
5 HOMEPAGE = "http://www.bluez.org"
6 LICENSE = "GPL"
7
8 # For angstrom we want this to replace at least bluez-libs
9 PROVIDES_append_angstrom = " bluez-libs"
10
11 PR = "r1"
12
13 SRC_URI = "\
14   http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
15   file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
16   file://sbc-thumb.patch;patch=1 \
17   file://bluetooth.conf \
18 "
19 S = "${WORKDIR}/bluez-${PV}"
20
21 inherit autotools_stage
22 AUTOTOOLS_STAGE_PKGCONFIG = "1"
23
24 EXTRA_OECONF = "\
25   --enable-gstreamer \
26   --enable-alsa \
27   --enable-usb \
28   --enable-netlink \
29   --enable-tools \
30   --enable-bccmd \
31   --enable-hid2hci \
32   --enable-dfutool \
33   --enable-hidd \
34   --enable-pandd \
35   --enable-dund \
36   --disable-cups \
37   --enable-test \
38   --enable-manpages \
39   --enable-configfiles \
40   --enable-initscripts \
41   --disable-pcmciarules \
42 "
43
44 do_install_append() {
45         install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
46         install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
47         install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
48         # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
49         install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
50 }
51
52 PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
53
54 FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
55 FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
56 FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
57 FILES_${PN}-dev += "\
58   ${libdir}/bluetooth/plugins/*.la \
59   ${libdir}/alsa-lib/*.la \
60   ${libdir}/gstreamer-0.10/*.la \
61 "
62
63 FILES_${PN}-dbg += "\
64   ${libdir}/bluetooth/plugins/.debug \
65   ${libdir}/*/.debug \
66 "