libgcrypt: restore BBCLASSEXTEND
[openembedded.git] / recipes / blueman / blueman_1.21.bb
1 DESCRIPTION = "Blueman GTK+ Bluetooth Manager, designed for common bluetooth tasks."
2 HOMEPAGE = "http://blueman-project.org/"
3 SECTION = "optional"
4
5 DEPENDS = "gtk+ glib-2.0 bluez4 intltool python \
6            python-native python-pyrex \
7            startup-notification \
8 "
9
10 RDEPENDS = "python-dbus python-pygobject python \
11             dbus bluez4 python-pygtk obex-data-server \
12             python-subprocess \
13 "
14
15 PR = "r4"
16
17 SRC_URI = "http://download.tuxfamily.org/blueman/blueman-${PV}.tar.gz"
18
19 inherit autotools pkgconfig python-dir
20
21 EXTRA_OECONF += "--with-no-runtime-deps-check"
22
23 do_configure_prepend() {
24     sed -i "s/py_prefix=.*$/py_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
25     sed -i "s/py_exec_prefix=.*$/py_exec_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
26 }
27
28 FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"
29 FILES_${PN} += "${libdir} ${datadir}"
30
31 BLUEZ_LIBS = "-L${libdir} -lbluetooth"
32 BLUEZ_CFLAGS = "-I${includedir}"