utils.bbclass: restore previous implementation of explode_deps()
[openembedded.git] / recipes / avahi / avahi-ui_0.6.25.bb
1 require avahi.inc
2
3 PR = "r1"
4
5 DEPENDS += "avahi gtk+"
6
7 AVAHI_GTK = "--enable-gtk"
8
9 S = "${WORKDIR}/avahi-${PV}"
10
11 do_stage() {
12         install -d ${STAGING_INCDIR}/avahi-ui
13         cp ${S}/avahi-ui/*.h ${STAGING_INCDIR}/avahi-ui/
14         oe_libinstall -C avahi-ui -a -so libavahi-ui ${STAGING_LIBDIR}
15 }
16
17 PACKAGES = "${PN} ${PN}-dbg"
18
19 FILES_${PN} = "${libdir}/libavahi-ui*.so.*"
20 FILES_${PN}-dbg += "${libdir}/.debug/libavah-ui*"