rename packages/ to recipes/ per earlier agreement
[openembedded.git] / recipes / anthy / anthy_9100e.bb
1 DESCRIPTION = "A Japanese input method"
2 DESCRIPTION_anthy = "A Japanese input method (backend, dictionary and utility)"
3 DESCRIPTION_libanthy0 = "Anthy runtime library"
4 DESCRIPTION_libanthy-dev = "Anthy static library, headers and documets for developers"
5 AUTHOR = "Anthy Developers <anthy-dev@lists.sourceforge.jp>"
6 HOMEPAGE = "http://anthy.sourceforge.jp"
7 SECTION = "inputmethods"
8 SECTION_libanthy0 = "libs/inputmethods"
9 SECTION_libanthy-dev = "devel/libs"
10 LICENSE = "GPL"
11 DEPENDS = "anthy-native"
12 PR = "r3"
13
14 SRC_URI = "http://osdn.dl.sourceforge.jp/anthy/29142/anthy-9100e.tar.gz \
15            file://not_build_elc.patch;patch=1 \
16            file://2ch_t.patch;patch=1 \
17            file://native-helpers.patch;patch=1"
18
19 inherit autotools pkgconfig
20
21 # gettext
22
23 LEAD_SONAME = "libanthy.so.0"
24 RDEPENDS_anthy = "libanthy0"
25
26 do_stage() {
27         autotools_stage_all
28 }
29
30 PACKAGES += "${PN}-el libanthy0 libanthy-dev"
31 FILES_${PN}-dbg += "${libdir}/.debug"
32 FILES_libanthy0 = "${libdir}/libanthy.so.*      \
33                            ${libdir}/libanthydic.so.*   \
34                            ${libdir}/libanthyinput.so.*"
35 FILES_libanthy-dev = "${libdir}/libanthy*.la \
36                       ${libdir}/libanthy*.a \
37                       ${libdir}/libanthy*.so \
38                               ${includedir}/anthy       \
39                               ${libdir}/pkgconfig/anthy.pc"
40 FILES_${PN}-el = "${datadir}/emacs/*"
41 FILES_${PN} = "${datadir}/* \
42                ${bindir}/* \
43                ${sysconfdir}/anthy-conf"