angstrom-uboot-scripts: Used beaglerev variable
[openembedded.git] / recipes / angstrom / angstrom-uboot-scripts.bb
1 DESCRIPTION = "Various uboot scripts"
2
3 PR = "r4"
4
5 DEPENDS = "u-boot-mkimage-native"
6
7 SRC_URI = "file://*.cmd"
8
9 do_configure() {
10         cp ${WORKDIR}/*.cmd ${S}
11
12         for i in *.cmd ; do
13                 mv $i uboot-$i
14         done
15 }
16
17 do_compile() {
18         for i in *.cmd ; do
19                 uboot-mkimage -A ${TARGET_ARCH} -O linux -T script -C none -a 0 -e 0 -n "Angstrom $i" -d $i $i.scr
20         done
21 }
22
23 do_install() {
24         install -d ${D}/boot/u-boot-scripts
25         for i in *.cmd *.scr ; do
26                 install -m 0644 $i ${D}/boot/u-boot-scripts
27         done
28 }
29
30 FILES_${PN} += "/boot"
31
32 addtask deploy before do_package after do_install
33
34 do_deploy() {
35         install -d ${DEPLOY_DIR_IMAGE}
36         for i in *.scr ; do
37                 cp $i ${DEPLOY_DIR_IMAGE}
38                 package_stagefile_shell ${DEPLOY_DIR_IMAGE}/$i
39         done
40 }
41
42 PACKAGE_ARCH = "${MACHINE_ARCH}"