Merge branch 'org.openembedded.dev' of git+ssh://git.openembedded.org/openembedded...
[openembedded.git] / recipes / alsa / alsa-lib_1.0.17.bb
1 DESCRIPTION = "Alsa sound library"
2 HOMEPAGE = "http://www.alsa-project.org"
3 SECTION = "libs/multimedia"
4 LICENSE = "LGPL"
5
6 # configure.in sets -D__arm__ on the command line for any arm system
7 # (not just those with the ARM instruction set), this should be removed,
8 # (or replaced by a permitted #define).
9 #FIXME: remove the following
10 ARM_INSTRUCTION_SET = "arm"
11
12 SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
13            file://fix-tstamp-declaration.patch;patch=1 \
14            file://fix_libmath.patch;patch=1 \
15           "
16
17 inherit autotools pkgconfig
18
19
20 EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
21
22
23 require alsa-fpu.inc
24 EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
25
26
27 require alsa-versym.inc
28 EXTRA_OECONF += "${@get_alsa_versym_setting(bb, d)} "
29
30
31 do_stage () {
32         autotools_stage_all
33 }
34
35 PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
36 FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*"
37 FILES_libasound = "${libdir}/libasound.so.*"
38 FILES_alsa-server = "${bindir}/*"
39 FILES_alsa-conf = "${datadir}/alsa/"
40 FILES_alsa-dev += "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*"
41 FILES_alsa-conf-base = "\
42 ${datadir}/alsa/alsa.conf \
43 ${datadir}/alsa/cards/aliases.conf \
44 ${datadir}/alsa/pcm/default.conf \
45 ${datadir}/alsa/pcm/dmix.conf \
46 ${datadir}/alsa/pcm/dsnoop.conf"
47
48 RDEPENDS_libasound = "alsa-conf-base"