Merge branch 'org.openembedded.dev' of git+ssh://git.openembedded.org/openembedded...
[openembedded.git] / recipes / alsa / alsa-lib_1.0.15.bb
1 DESCRIPTION = "Alsa sound library"
2 HOMEPAGE = "http://www.alsa-project.org"
3 SECTION = "libs/multimedia"
4 LICENSE = "LGPL"
5 PR = "r1"
6
7 # configure.in sets -D__arm__ on the command line for any arm system
8 # (not just those with the ARM instruction set), this should be removed,
9 # (or replaced by a permitted #define).
10 #FIXME: remove the following
11 ARM_INSTRUCTION_SET = "arm"
12
13 SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
14            file://fix-tstamp-declaration.patch;patch=1 \
15            file://fix_libmath.patch;patch=1 \
16           "
17
18 inherit autotools pkgconfig
19
20
21 EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
22
23
24 require alsa-fpu.inc
25 EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
26
27
28 require alsa-versym.inc
29 EXTRA_OECONF += "${@get_alsa_versym_setting(bb, d)} "
30
31
32 do_stage () {
33         oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
34         install -d ${STAGING_INCDIR}/alsa/sound
35         install -m 0644 include/*.h ${STAGING_INCDIR}/alsa/
36         install -m 0644 include/sound/ainstr*.h ${STAGING_INCDIR}/alsa/sound/
37         install -d ${STAGING_DATADIR}/aclocal
38         install -m 0644 utils/alsa.m4 ${STAGING_DATADIR}/aclocal/
39 }
40
41 PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
42 FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*"
43 FILES_libasound = "${libdir}/libasound.so.*"
44 FILES_alsa-server = "${bindir}/*"
45 FILES_alsa-conf = "${datadir}/alsa/"
46 FILES_alsa-dev += "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*"
47 FILES_alsa-conf-base = "\
48 ${datadir}/alsa/alsa.conf \
49 ${datadir}/alsa/cards/aliases.conf \
50 ${datadir}/alsa/pcm/default.conf \
51 ${datadir}/alsa/pcm/dmix.conf \
52 ${datadir}/alsa/pcm/dsnoop.conf"
53
54 RDEPENDS_libasound = "alsa-conf-base"