merge of '440352b74d1975abf361c30e00a2519bd5c8051e'
[openembedded.git] / packages / tasks / task-qpe.bb
1 DESCRIPTION = "Tasks for programs running on Qt/Embedded based Palmtop Environents like Opie and Qtopia."
2 SECTION = "opie/base"
3 ALLOW_EMPTY = 1
4 PACKAGE_ARCH = "all"
5 LICENSE = "MIT"
6 PR = "r8"
7
8 PACKAGES = "task-qpe-applets task-qpe-games task-qpe-inputmethods \
9         task-qpe-multimedia task-qpe-emulators task-qpe-applications \
10         task-qpe-fonts task-qpe-settings"
11
12 RDEPENDS_task-qpe-applets = "\
13     subapplet \
14     tasklistapplet"
15
16 RDEPENDS_task-qpe-applications = "\
17     camera-assistant \
18     cumulus \
19     dviviewer \
20     freenote \
21     inkwp \
22     iqnotes \
23     justreader \
24     keyring \
25     klimt \
26     kstars-embedded \
27     ktimetrackerpi \
28     mileage \
29     militaryalphabet \
30     notez \
31     petitepainture \
32     pocketcellar \
33     poqetpresenter \
34     portabase \
35     qpdf2 \
36     qpealarmclock \
37     qpe-gaim \
38     qpegps \
39     qpenmapfe \
40     qplot \
41     qpphoto \
42     resistorui \
43     shopper \
44     sliderulez \
45     timesleuth \
46     txdrug \
47     tximage \
48     ubahnnav \
49     visiscript \
50     xqt2 \
51     zeecookbook \
52     zbedic \
53     zbench \
54     zgscore \
55     zipsc \
56     zlapspeed \
57     zroadmap \
58     zshopi"
59
60 RDEPENDS_task-opie-decorations = "\
61     opie-deco-flat \
62     opie-deco-liquid \
63     opie-deco-polished"
64
65 RDEPENDS_task-qpe-games = "\
66     aliens \
67     aliens-qt \
68     atomic \
69     billiardz \
70     brickout \
71     checkers \
72     crossword \
73     fish \
74     froot \
75     gemdropx \
76     glider \
77     hexatrolic \
78     iaimaster \
79     icebloxx \
80     knights \
81     labyrinth \
82     mahjongg \
83     maki \
84     nmm \
85     pairs \
86     pdamaze \
87     pipeman \
88     pipepanic \
89     powermanga \
90     puzz-le \
91     qfish2 \
92     qpe-vexed \
93     qmatrix \
94     shisensho \
95     sokoban \
96     tickypip \
97     tickypip-levels \
98     tron \
99     vectoroids \
100     win4 \
101     zauralign \
102     zddice \
103     ziq \
104     zmerlin \
105     zrally \
106     zrev7 \
107     zsubhunt \
108     ztappy \
109     zudoku"
110
111 RDEPENDS_task-qpe-inputmethods = "\
112     custominput \
113     flexis-zaurus \
114     irk-targus \
115     irk-belkin"
116
117 RDEPENDS_task-qpe-multimedia = "\
118     mplayer \
119     sidplayer \
120     xmms-embedded"
121
122 RDEPENDS_task-kdepim = "\
123     kopi \
124     kapi \
125     kopi-applet"
126
127 RDEPENDS_task-qpe-emulators = "scummvm"
128
129 RDEPENDS_task-qpe-fonts = "\
130     qpf-bitstream-vera-large \
131     qpf-bitstream-vera-sans-mono-huge \
132     qpf-freemono \
133     qpf-freeserif \
134     ttf-gentium \
135     qpf-hunkysans \
136     qpf-hunkyserif \
137     qpf-qte \
138     qpf-helvetica \
139     qpf-unifont \
140     qpf-utopia \
141     terminus"
142
143 RDEPENDS_task-qpe-settings += "\
144     qclockchange"
145