merge of a3eaa78e93ce09edb93d710e411a9ec816ded220
[openembedded.git] / packages / tasks / task-qpe.bb
1 DESCRIPTION = "Tasks for programs running on Qt/Embedded based Palmtop Environents like Opie and Qtopia."
2 SECTION = "opie/base"
3 ALLOW_EMPTY = 1
4 PACKAGE_ARCH = "all"
5 LICENSE = "MIT"
6 PR = "r6"
7
8 PACKAGES = "task-qpe-applets task-qpe-games task-qpe-inputmethods \
9         task-qpe-multimedia task-qpe-emulators task-qpe-applications \
10         task-qpe-fonts task-qpe-settings"
11
12 RDEPENDS_task-qpe-applets = "\
13     subapplet \
14     tasklistapplet"
15
16 RDEPENDS_task-qpe-applications = "\
17     camera-assistant \
18     cumulus \
19     dviviewer \
20     freenote \
21     inkwp \
22     iqnotes \
23     justreader \
24     keyring \
25     klimt \
26     kstars-embedded \
27     ktimetrackerpi \
28     mileage \
29     militaryalphabet \
30     notez \
31     petitepainture \
32     pocketcellar \
33     poqetpresenter \
34     portabase \
35     qpdf2 \
36     qpealarmclock \
37     qpe-gaim \
38     qpegps \
39     qpenmapfe \
40     qplot \
41     qpphoto \
42     resistorui \
43     shopper \
44     sliderulez \
45     timesleuth \
46     txdrug \
47     tximage \
48     ubahnnav \
49     visiscript \
50     xqt2 \
51     zeecookbook \
52     zbedic \
53     zbench \
54     zgscore \
55     zipsc \
56     zlapspeed \
57     zroadmap \
58     zshopi"
59
60 RDEPENDS_task-opie-decorations = "\
61     opie-deco-flat \
62     opie-deco-liquid \
63     opie-deco-polished"
64
65 RDEPENDS_task-qpe-games = "\
66     aliens \
67     aliens-qt \
68     atomic \
69     billiardz \
70     brickout \
71     checkers \
72     crossword \
73     fish \
74     froot \
75     gemdropx \
76     glider \
77     gnuz \
78     hexatrolic \
79     iaimaster \
80     icebloxx \
81     knights \
82     labyrinth \
83     mahjongg \
84     maki \
85     nmm \
86     pairs \
87     pdamaze \
88     pipeman \
89     pipepanic \
90     powermanga \
91     puzz-le \
92     qfish2 \
93     qpe-vexed \
94     qmatrix \
95     shisensho \
96     sokoban \
97     tickypip \
98     tickypip-levels \
99     tron \
100     vectoroids \
101     win4 \
102     zauralign \
103     zddice \
104     ziq \
105     zmerlin \
106     zrally \
107     zrev7 \
108     zsubhunt \
109     ztappy"
110
111 RDEPENDS_task-qpe-inputmethods = "\
112     custominput \
113     flexis-zaurus \
114     irk-targus \
115     irk-belkin"
116
117 RDEPENDS_task-qpe-multimedia = "\
118     mplayer \
119     sidplayer \
120     xmms-embedded"
121
122 RDEPENDS_task-kdepim = "\
123     kopi \
124     kapi \
125     kopi-applet"
126
127 RDEPENDS_task-qpe-emulators = "scummvm"
128
129 RDEPENDS_task-qpe-fonts = "\
130     qpf-bitstream-vera-large \
131     qpf-bitstream-vera-sans-mono-huge \
132     qpf-dejavusans \
133     qpf-dejavusanscondensed \
134     qpf-dejavusansmono \
135     qpf-dejavuserif \
136     qpf-dejavuserifcondensed \
137     qpf-freemono \
138     qpf-freeserif \
139     ttf-gentium \
140     qpf-hunkysans \
141     qpf-hunkyserif \
142     qpf-qte \
143     qpf-helvetica \
144     qpf-unifont \
145     qpf-utopia \
146     terminus"
147
148 RDEPENDS_task-qpe-settings += "\
149     qclockchange"
150