a331e8caaddd79ebcdaf7651684a4ad962895dd1
[openpandora.oe.git] / packages / pandora-system / pandora-wifi_git.bb
1 DESCRIPTION = "Kernel drivers for the TI1251 WiFi chip found on the Pandora - Connected via SDIO"
2 LICENSE = "GPLv2"
3
4 PR = "r9"
5
6 # Check the include for the source location/GIT SRCREV etc.
7 require pandora-wifi.inc
8
9 SRC_URI += " \
10         file://rc.tiwifi \
11 "
12
13 inherit update-rc.d
14
15 INITSCRIPT_NAME = "tiwifi-init"
16 INITSCRIPT_PARAMS = "start 30 5 2 . stop 40 0 1 6 ."
17
18 do_compile_prepend() {
19           cd ${S}/sta_dk_4_0_4_32/
20 }
21
22 do_install() {
23           cd ${S}/sta_dk_4_0_4_32/
24           mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net
25           cp ${S}/sta_dk_4_0_4_32/*.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net
26           install -d ${D}${sysconfdir}/init.d/
27           cp -pP ${WORKDIR}/rc.tiwifi ${D}${sysconfdir}/init.d/tiwifi-init
28 }
29
30 FILES_${PN} += "/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/*.ko.*"